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Introduction 

The OmniServer User Configurable OPC Server is a powerful tool that allows users to define a protocol 

patterned to match the data format of their non-standard scales, barcode readers and other devices.  

However, this can be a daunting task for anyone who has never configured a protocol using a user 

configurable server. 

Inconsistent device documentation and confusing protocol specifications can further increase the difficulty 

of getting a protocol working and passing data from your devices to your HMI applications.  The good news 

is that OmniServer has some very basic but powerful diagnostics tools that can help determine why a 

protocol is not working properly. 

This document will detail the most basic steps that can be taken to troubleshoot a protocol implementation 

in your OmniServer installation.  These are the very first steps that our support engineers follow to 

determine where a problem lies with a protocol.  The diagnostics tools at our disposal that will be shown 

throughout this document are the following: 

1. The OmniServer Item Values Window 

2. The OmniServer Logger Window 

3. The OmniServer I/O Monitor Window 

Several assumptions are made within this document.  It is assumed that you have a Protocol, Device and 

Topic defined in your OmniServer configuration.  It is assumed that the protocol contains at least one item 

and one Host or Unsolicited Message being used for communication with your device. 

It is further assumed that the Device configured has the correct communication settings necessary for 

communicating with your device (Baud Rate, Flow Control, IP Address, etc.).  It is also assumed that the 

Topic has been configured using the correct defined Protocol and Device. 
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Using the OmniServer Item Values Window 

If you are having trouble communicating with your device using OmniServer, the first place to look is the 

Item Values Window.  This can be found by going to View -> Diagnostics -> Item Values.  This screen 

displays all configured topics, status items and topic variables for those topics and all active items for the 

protocols associated with those topics as shown in Figure 1 below. 

 

Figure 1:  Item Values Window 

This is very useful for determining if there is even a client connection between your HMI application and 

OmniServer.  You will notice that the only thing displayed in the figure above is the Topic “test” and the 

status item and topic variable (since the test protocol is using a topic variable) for that topic. 

This indicates that we do not have a client connected to OmniServer requesting data for at least one item 

from the “test” topic’s associated protocol.  This is important because OmniServer absolutely will not 

communicate with your device if a client application is not actively requesting data for at least one item in 

your protocol.  As you can see in Figure 2 below, a client is now connected and requesting data for the item 

“ao1”. 

 

Figure 2:  Active Item 

This is one of the easiest tests to perform and it helps to eliminate the client application to OmniServer 

connection as part of the problem.  If you look in the Item Values Window and there is only the “Status” item 
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listed for your topic, then you need to double-check your client application settings for connecting to 

OmniServer. 

If you look in the Item Values Window and your item is listed under your topic but you are not getting any 

data for that item at all in your client application, the problem typically either lies with the device 

communication settings/cabling or the OmniServer protocol message pattern being incorrect. 
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Using the OmniServer Logger Window 

To view the OmniServer Logger, go to View -> Diagnostics -> Logger, as shown in Figure 3 below. 

 

Figure 3:  Opening the Logger 

You can configure whether or not the Logger will display Data Sends, Data Receives, Events and Errors, as 

shown in Figure 4 below.  It is recommended that you have all of these selections enabled for diagnostic 

purposes. 

 

Figure 4:  Logging Options 

 



Page 7 of 14 

The OmniServer Logger will display informational events and messages pertaining to any errors that might 

have occurred.  If there are any problems with communications settings or conflicts, an error should be 

displayed here.  For example, if another program is already accessing a COM port, you will see an “Access 

Denied” notification as shown in Figure 5 below. 

 

Figure 5:  COM Error 

Framing or parity errors can sometimes be displayed when communications settings are incorrect or there 

is faulty cabling involved.  For Ethernet communications, Winsock errors generated by Windows can 

sometimes be displayed when there are communications problems.  A listing and description of Windows 

Sockets (Winsock) Error Codes can be found at http://msdn2.microsoft.com/en-us/library/ms740668.aspx . 

If you have verified that you are connected with your client application, are not getting data and have errors 

in the OmniServer Logger that you cannot resolve, please contact technical support for assistance. 

If you have verified you are connected to OmniServer with your client application and there are no errors in 

the Logger, the next diagnostic tool we can use is the OmniServer I/O Monitor (Page 8). 

You can save the data from the Logger into a text file for diagnostic purposes by going to File -> Snapshot 
as shown in Figure 6 below. 

 

Figure 6:  Logger Snapshot 

This creates a file named “snapshot.txt” in the default directory where you have installed OmniServer. 

 

http://msdn2.microsoft.com/en-us/library/ms740668.aspx
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Using the OmniServer I/O Monitor 

The I/O Monitor is a diagnostic and informational tool that displays both the data being transmitted to your 

devices and the data being received from your devices for the selected device or topic.  If there is a problem 

in the protocol itself, the I/O Monitor allows us to see the actual data bytes being sent and received.  This 

allows us to compare the actual data with the pattern in the protocol messages and determine what the 

problem is. 

To open the I/O Monitor, go to View -> Diagnostics -> I/O Monitor as shown in Figure 7 below. 

 

Figure 7:  Opening I/O Monitor 

The I/O Monitor Tool Bar allows you to control the listing behavior of the I/O Monitor and is shown in Figure 
8 below. 

 

Figure 8: I/O Monitor Tool Bar 
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The I/O Stream Selector allows you to select a server device or topic for which you would like to view the 

data sent to and received from the device as shown in Figure 9 below. 

 

Figure 9:  I/O Stream Selector 

The Resume Listing (Green) button resumes listing the sends and receives if they have been halted by the 

Halt Listing (Red) button, both shown below listed respectively from left to right in Figure 10. 

 

Figure 10:  Resume and Halt Listing Buttons 

The Snapshot (Camera) button, shown in Figure 11 below, allows you to take an HTML snapshot of the 

sends and receives as they are shown in the I/O Monitor.  This saves a file called “io_monitor.html” in the 

default directory where you have installed OmniServer. 

 

Figure 11:  Snapshot Button 

The last button in the I/O Monitor Tool Bar is the Colors Key, shown in below with the button expanded. 

 

Figure 12:  Colors Key 
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This key displays the possible colors of data that can populate the I/O Monitor and what they are.  A 

description of each is listed below. 

1. Send – Data sent by Omniserver to the instrument.  This would be Host Messages configured in 

your protocol. 

2. Unknown – Data sent by the device to OmniServer that has not been processed.  This normally 

means that the Response portion of a Host Message or Received portion of an Unsolicited 

Message in your protocol does not match the pattern of data received by OmniServer. 

3. Receive – Data sent by the device to OmniServer that has been processed and matched a 

message in your protocol. 

4. Ignore – Data sent by the device to OmniServer that has been processed but did not match any 

message in the protocol.  This means that there is at least one byte in your Response or Received 

message in the protocol that does not exactly match the pattern of the data being received. 

5. Fail – Data sent by the device to OmniServer that failed an Error Detection Code (EDC) check.  

This would only ever be possible if your device uses Error Detection such as a checksum. 

If communications between OmniServer are occurring successfully, you should only see black sends and 

green receives in the I/O Monitor if you are polling your devices for responses (Figure 13) or only green 

receives if your devices are sending data to OmniServer in an unsolicited manner. 

 

Figure 13:  Good Communications 
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If you see only black data (Figure 14) in the I/O Monitor, there could be one of two problems: 

1. The format of the Request portion of the Host Message in your OmniServer protocol is not correct 

so your device does not recognize the request or command that is being sent to it. 

2. There is a problem with the cabling to the device or the device itself such that the device either is 

not receiving the request or the device is not responding to the request. 

 

Figure 14:  No Response 

This is normally caused by the Host Message format being incorrect, so you will want to compare the 

necessary format for the command or request in your device’s protocol documentation to what you have 

configured in your OmniServer protocol.  Even one incorrect byte/character will cause the command or 

request to fail so you will need to compare the documented format closely to your protocol. 

If you see black and blue or magenta data in the I/O Monitor (Figure 15), you will need to compare the blue 

or magenta data in the I/O Monitor with your received or response messages in the Omniserver Protocol. 

 

Figure 15:  Unknown Format 
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If we were to look at the Response portion of the Host Message for this protocol (), we should be able to 

see a difference in the pattern in the protocol and the magenta and blue response in the I/O Monitor. 

 

Figure 16:  Host Message Response 

We see the following response sequence in magenta and blue in the I/O Monitor: 

01 03 02 00 9D 79 ED 

The first thing to check is that the total number of bytes in the pattern in the Response Message matches 

the number of bytes we have received.  The response from the device is seven bytes long.  If we break 

down the response in the protocol, we will see the following: 

1. {TV:1UB} – 1 Byte 

2. \x2 – 1 Byte 

3. {AO{Address}:2UB} – 2 Bytes 

4. {$CRC16-RA001-N1:2UBO12} – 2 Bytes 

If you add the number of bytes total in the response message, you can see that there are only six bytes 

configured in that pattern.  If you compare the two a little more closely, you can see that there is a “\x3” 

sequence missing in the response message. 

The first byte in the I/O Monitor is magenta because it matched the defined message but the whole 

message did not match.  This indicates that after the first byte, the rest of the sequence was not processed.  

If you look at the second byte in the I/O Monitor, there is a “\x3” sequence and the third byte is the “\x2” 

sequence defined in the response message. 

Since there is a missing byte, the pattern in the response message does not match the data OmniServer 

has received from the device and cannot complete processing the received data.  To successfully 
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communicate, the response would need to have the missing sequence added, as shown in Figure 17 

below. 

 

Figure 17:  Correct Response Message 

The rule to remember is that every byte received from a device must be accounted for in your response or 

received message in the OmniServer protocol.  The messages in your OmniServer protocol are the patterns 

that received device data are matched against.  If there is no match, there is no way for OmniServer to pass 

the correct data to the client application. 
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Support 

If you are able to go through the steps in this troubleshooting guide and still are not able to establish 

communications with your device, you can contact Software Toolbox for support with your OmniServer 

problem.  There are four files that we will need to help troubleshoot your problem: 

1. OmniServer Protocol File (.DPD extension) 

2. OmniServer Configuration File (omnisrv.cfg) 

3. OmniServer I/O Monitor HTML File (io_monitor.html) – See Figure 11 

4. OmniServer Snapshot File (snapshot.txt) – See Figure 6 

Please zip those four files and e-mail them to our support engineers at support@softwaretoolbox.com .  Our 

experienced engineers can analyze the files to help you determine where the problem lies and help you 

establish communications successfully with your devices. 

Contact Us 

If you have any questions or are seeking further information and help: 

Online Support: http://support.softwaretoolbox.com.com/

E-Mail Support: support@softwaretoolbox.com

Phone Support: +1 (704) 849-2773 

Fax:   +1 (704) 849-6388 

Mailing Address: Software Toolbox, Inc.  148A East Charles Street, Matthews, NC, 28105  USA 
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